[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Building Make out of Git: Gettext requirements

From: Eli Zaretskii
Subject: Re: Building Make out of Git: Gettext requirements
Date: Sat, 20 Apr 2013 20:00:25 +0300

> Date: Sat, 20 Apr 2013 17:56:45 +0200
> From: Stefano Lattarini <address@hidden>
> CC: Eli Zaretskii <address@hidden>, address@hidden
> On 04/20/2013 05:44 PM, Paul Smith wrote:
> > On Sat, 2013-04-20 at 13:50 +0300, Eli Zaretskii wrote:
> >> Do we really need to require 0.18.1 or can this restriction be lifted?
> >> I hacked configure.ac to require 0.17, and didn't see any problems
> >> afterwards.
> > 
> > You can see this bug:
> > 
> > http://savannah.gnu.org/bugs/?37307
> > 
> > I confess I didn't get a satisfactory answer to my question, of why the
> > minimum version in configure.ac must be changed.  It seems to me that if
> > I build the make distribution tarball with a newer version of gettext,
> > regardless of the minimum version specified in configure.ac, it should
> > be good enough.
> >
> I'm not sure of this -- I believe that gettext tries to use the data files
> for the version actually specified in AM_GNU_GETTEXT_VERSION, even when a
> more modern gettext is being used;

Are you saying that, if AM_GNU_GETTEXT_VERSION specifies, say, 0.17,
but the person who runs autoreconf has _only_ 0.18 installed, then
autoreconf will fail because autopoint cannot find Gettext 0.17???

> for more details, see the commit message for this Automake commit
>   <http://git.savannah.gnu.org/cgit/automake.git/commit/?id=030ecb45>

That commit message seems to also suggest a work-around, or maybe I'm
missing something.

> This seems confirmed by the Gettext manual:
>     AM_GNU_GETTEXT_VERSION (in gettext.m4)
>     --------------------------------------
>     The AM_GNU_GETTEXT_VERSION macro declares the version number of the
>     GNU gettext infrastructure that is used by the package.
> See? There is no mention of "minimal required version number" --- it only
> speaks about "*the* version number".

What happens if there's no AM_GNU_GETTEXT_VERSION call in

> Not sure if and how this is relevant for your situation, but might be 
> something
> to consider.
> > However, Brad was clear that he believed that the minimum version MUST
> > be increased in configure.ac in order to get the benefits.
> >
> I believe he's right, in light of the above.

Even if he is, it is IMO wrong to punish everyone because of a single
platform, whose problem is not really fatal (static linking).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]