[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #50648] GMake 4.2.1 --with-guile fails silently if installed Guile

From: anonymous
Subject: [bug #50648] GMake 4.2.1 --with-guile fails silently if installed Guile version is higher than 2.0
Date: Mon, 27 Mar 2017 03:16:28 -0400 (EDT)
User-agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:51.0) Gecko/20100101 Firefox/51.0


                 Summary: GMake 4.2.1 --with-guile fails silently if installed
Guile version is higher than 2.0
                 Project: make
            Submitted by: None
            Submitted on: Mon 27 Mar 2017 07:16:27 AM UTC
                Severity: 3 - Normal
              Item Group: Bug
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any
       Component Version: 4.2.1
        Operating System: POSIX-Based
           Fixed Release: None
           Triage Status: None




This is on macOS with stock:


When you build --with-guile the configure script hard-codes "guile-2.0" (and
an earlier guile version) as the Guile package to check for.  But if you have
guile-2.2 or anything higher than 2.0, the check will fail and guile will not
be included.

This also causes the very convenient homebrew version of make to fail to
install with guile despite passing

homebrew install make --with-guile

In my case I had installed guile-2.2 via homebrew and the make builed failed
to find it.

The problem is NOT with homebrew; it is in the configure script that comes
with make

Is there a way to make that check for >= 2.0 rather than == 2.0?  That would
make it consistent with the stated goal in the make 4.0 release notes:


|Currently GNU Guile 1.8 and 2.0+ are supported.


Reply to this item at:


  Message sent via/by Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]