[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Autotools requirements are too recent

From: Jeffrey Walton
Subject: Autotools requirements are too recent
Date: Fri, 24 Aug 2018 19:46:32 -0400

$ autoreconf -f -i
configure.ac:35: error: require Automake 1.16.1, but have 1.15.1
autoreconf: automake failed with exit status: 1

Please consider dropping version requirements. I'm working on Fedora
28. Fedora is know for having some of the most up to date tools.

If something can't build on the latest Fedora there's no hope it can
build where a newer GNU Make is truly needed, like AIX 7, OS X 10.8,
Ubuntu 12, or Solaris 11.

(In fact I test some software back to Fedora 1 with GCC 2.9 and
Windows XP with Visual Studio .Net. Those are the machines I need to
update a handful of tools on. They won't have the bleeding edge stuff
Make is embracing).

Also consider, I could not care less if I have old Autotools. I don't
care if there's a bug or race during install. I'll live with the risk.
My job is to get a new Make on the machine, not dicking around with
Autotools versions. Anything that stops me from updating Make is a
distraction and waste of energy.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]