[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #55137] $(file …) is executed too early when used in recipe

From: Marcin Kasperski
Subject: [bug #55137] $(file …) is executed too early when used in recipe
Date: Fri, 30 Nov 2018 05:59:19 -0500 (EST)
User-agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:63.0) Gecko/20100101 Firefox/63.0


                 Summary: $(file …) is executed too early when used in
                 Project: make
            Submitted by: mekk
            Submitted on: Fri 30 Nov 2018 10:59:17 AM UTC
                Severity: 3 - Normal
              Item Group: Bug
                  Status: None
                 Privacy: Public
             Assigned to: None
             Open/Closed: Open
         Discussion Lock: Any
       Component Version: 4.2.1
        Operating System: POSIX-Based
           Fixed Release: None
           Triage Status: None



I tried using the following snippet:

    OUTPUT/something :
         mkdir -p OUTPUT
         $(file > $@, something)

It crashes with 
     OUTPUT/something: No such file or directory. Stop.

Moreover, looks like file is executed before anything else happens, even if I

    OUTPUT/something :
         $(file > $@, something)

I get the same error.

So I suppose file is executed too early, before earlier steps of the recipe
are completed. Here this causes failure, in other places it may cause writing
incorrect data.


See attached Makefile for full working example – compare
    make good
    make bad


File Attachments:

Date: Fri 30 Nov 2018 10:59:17 AM UTC  Name: Makefile  Size: 201B   By: mekk



Reply to this item at:


  Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]