[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Segafult while running make(1) from /lib/init/rc with -j

From: Alejandro Colomar (man-pages)
Subject: Segafult while running make(1) from /lib/init/rc with -j
Date: Thu, 6 Jan 2022 20:13:21 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Thunderbird/91.4.1


I wrote some script to use make(1) to run rc scripts in parallel.
When running make(1) without -j, it works fine. However, when I run it in parallel (-j2, for the simplest thing), I run into a segfault (when I'm lucky and the system doesn't simply black out forever).

I expected this kind of issues, and maybe make(1) has some assumptions that some resources are available which aren't at the time of running rc init scripts, and if it's that I'll assume my fault and stop trying to use make(1).

However, in case this is some obscure bug in make(1) (or glibc, as the report also mentions), I'll report it to you. I could try to write a simpler Makefile that runs let's say a few sleep(1)s at the beginning of the rc scripts, and see if that still reproduces the segfault, but for the moment, I'll share what I see with the real Makefile, in case it's useful to you:

[ 2.145704] make[169]: segfault at 7ffed5438f80 ip 00007f00f48227d7 sp 00007ffed5438f80 error 6 in libc-2.33.so[7f00f47de000+148000] [ 2.146108] Code: df ff ff e8 7b 17 0a 00 ba 01 00 00 00 e9 82 f3 ff ff 90 41 57 49 89 d7 41 56 41 55 41 54 55 48 89 fd 53 48 81 ec 18 05 00 00 <48> 89 34 24 89 4c 24 48 64 48 8b 04 25 28 00 00 00 48 89 84 24 08
make: *** [Makefile:66: S] Segmentation fault

Does it make any sense?



Alejandro Colomar
Linux man-pages maintainer; http://www.kernel.org/doc/man-pages/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]