[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #63330] readdir() error in 4.4 on Solaris 8

From: Paul D. Smith
Subject: [bug #63330] readdir() error in 4.4 on Solaris 8
Date: Tue, 8 Nov 2022 00:49:47 -0500 (EST)

Follow-up Comment #5, bug #63330 (project make):

That's certainly disturbing and I would very much like to figure out what's
wrong.  Just to be sure I built and ran the GNU Make regression tests on an
NFS-mounted partition and it worked fine, but this was a GNU/Linux client and
a NetApp NFS server so very different.  I unfortunately don't have access to a
Solaris system.

It's hard to understand how a simple readdir() on an NFS directory would
return EOVERFLOW.  The only thing I can think of is that your version of GNU
make was not built with large file support enabled, and your NFS partition has
sizes >4G, but that should not be the case as we include the gnulib largefile
module.  Solaris 8 was released 22 years ago and went EOL >10 years ago, but
presumably the largefile support will work there regardless.

Just to be clear, when you said that GNU Make 4.3 worked OK did you mean it
worked on this same NFS partition where GNU Make 4.4 fails?

Can you either attach to this bug, or email to me directly at psmith@gnu.org,
the config.log file and config.status file from the GNU Make 4.4 configure


Reply to this item at:


Message sent via Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]