[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Parted 1.4.19

From: Larry Williams
Subject: Parted 1.4.19
Date: Mon, 8 Oct 2001 14:35:42 -0500

Hi all

Let me start by establishing :
1. I'm a relative Newbie (1.5 year)
2. My OS is Red Hat Ver 7.1, with 2.4.6 kernel
3. Base Hwd is dual Pentium III @ 600MHz and 512 MB Memory

Recently I used Parted Ver 1.4.19 to move my 80% full, /usr, to a larger 
partition. I used the "partboot.img", boot disk after getting a warning 
message while trying to use copy command. However, everything worked 
flawlessly, as advertised.

I would like to suggest one improvement, if I may. It would be nice to have a 
progress indicator option for copying large filesystems. The one I moved was 
2.3 GB and took so long, I almost interferred thinking something went wrong. 
I didn't time it but a reasonable estimate of 24-25 minutes is very close. 
That nets out to about 1 minute per MB. I don't know if this "normal" or not, 
but with 2 CPU's and a half Gig of memory, I sort of thought it would be 
faster. Please understand, this in no way, is meant to be a complaint, just 
an observation. Perhaps it might have been the method I used.

My scenario :
1. Unused, partition pre-made with fdisk and mke2fs.
2. Boot with Parted Boot Disk and enter interactive mode, "parted /dev/hda"
3. cp 5 12 ( a long scary wait, no prompt, no indication).
4. resize 12 1281 1955 (fast response)
5. quit ( /usr now in both partitions)
6. Boot up normally ( old /usr in effect)
7. Modify /etc/fstab
8. Re-boot ( new /usr in effect now and showing 49% full)

In my opinion, Parted is the best thing since sliced bread. I just learned of 
it's existance and thought I'd try it rather than re-installing. Again, it 
worked flawlessly.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]