[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: resizing root??

From: Erick Calder
Subject: RE: resizing root??
Date: Fri, 12 Oct 2001 13:21:14 -0700

I missed steps (1) and (2) in the first posting...  so I went back at
Andrew's suggestion and first tried to create a Parted boot disk which
failed with the following results (exceprted from another posting):

> I've tried both the .19 and .18 versions of partboot but have been unable
to boot from it...  I
> keep getting a:
> 1007
> AX:020A
> BX:0000
> CX:0009
> DX:0000
> over and over, just scrolling off the screen.  I've verified that the
floppy drive works and have
> specifically tested that floppy disk by making it a boot disk and booting
from it...

so now I realise I can't get to step (3)... but even if I did, I'd still
have the same problem: parted and all its libraries don't fit into a 1.44M

-----Original Message-----
From:   Larry Williams [mailto:address@hidden
Sent:   Friday, October 12, 2001 8:48 AM
To:     Erick Calder
Cc:     address@hidden
Subject:        Re: resizing root??

On Thursday 11 October 2001 14:19 pm, you wrote:
> hi, I have a single disk on my RedHat 7.0 box partitioned thusly:
> Minor   Start     End    Type            Filesystem     Flags
> 1          0.0  38154.4  primary         ext2           boot
> 2      38154.4  38162.2  extended
> 5      38154.4  38162.2  logical         linux-swap
> (parted)
> I want to shrink the first partition but since it contains the root (df
> -k):
> Filesystem           1k-blocks      Used Available Use% Mounted on
> /dev/hda1             38456308   2628584  33874224   8% /
> I need to unmount it before I shrink... which I can't do.  the anser seems
> to be booting from a floppy (which I can do).
> MY PROBLEM: is that parted, and all the libs it requires:
> # rpm -qR parted
> ld-linux.so.2
> libc.so.6
> libncurses.so.5
> libreadline.so.4.1
> libuuid.so.1
> libc.so.6(GLIBC_2.0)
> libc.so.6(GLIBC_2.1)
> libc.so.6(GLIBC_2.1.3)
> are MUCH bigger than I can fit in a floppy, and, as you can see I can't
> make a temporary partition that I could mount while booted up from floppy
> so I could put parted there...
> suggestions anyone??
> 1,000 thanks - e r i c k
> _______________________________________________
> Bug-parted mailing list
> address@hidden
> http://mail.gnu.org/mailman/listinfo/bug-parted

I have Red Hat 7.1 and I downloaded the tarball for parted 1.4.19 and
out a 28 page users guide which gives where to and how to for a boot disk. I
followed these instructions to the letter and had no problems booting, using
bootdisk "partboot.img" and then successfully copying a 2.3 GB partition to
new location. see instruction 1.5 in the users guide.

good luck


reply via email to

[Prev in Thread] Current Thread [Next in Thread]