[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem compiling Parted

From: Andrew Clausen
Subject: Re: Problem compiling Parted
Date: Mon, 15 Oct 2001 08:34:58 +1000
User-agent: Mutt/1.2.5i

On Sun, Oct 14, 2001 at 01:51:36PM -0400, Jean-S├ębastien Guay wrote:
> Greetings,
> I just tried to compile Parted 1.4.20, and I got the following error :
> make[3]: *** No rule to make target 
> `../../../common/parted-stable/libparted/crc32.c', needed by `crc32.lo'. 
> Stop.
> I did a `make clean' then re-ran ./configure and make, and got the same 
> error. The configure script runs perfectly.

Grrr, it looks like automake didn't run properly.  I'll upload a new
tarball.  Since it requires no changes to the source, I will release as
the same version.

> (at first it told me I needed e2fsprogs, but now that I've compiled, 
> installed and install-libs'ed that, configure seems to do all that it's 
> supposed to...)
> What could be the problem?

No, I can reproduce the problem here too.

It's extremely strange.  I did:

        $ make clean
        $ make
        $ make dist

(all worked)
But the generated tarball was broken.  Running automake on the tarball
fixed it.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]