[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem resizing ext2 filesystem on LVM

From: Andrew Clausen
Subject: Re: Problem resizing ext2 filesystem on LVM
Date: Tue, 8 Jan 2002 08:45:11 +1100
User-agent: Mutt/1.2.5i

On Mon, Jan 07, 2002 at 09:01:30PM +0100, Dave Wapstra wrote:
> Hi,
> I'm having some problems resizing an ext2 partition on a LVM Logical Volume. 
> The filesystem is currently approx. 
> 170GB, the LV is about 200GB.  Parted seems to resize fine, no error messages 
> are given.  However, the filesystem  
> is not resized and the size stays the same.

How longs does the resize take?  It appears to do real work?

> I've resize the filesystem this way before from ~140GB to ~170GB and that 
> worked fine.  Using parted 1.4.13 or 
> 1.4.22 gives the same result.

This is strange.

(1) parted's bureaucracy told it to resize to the same size.  In the
ext2 case, the time spent is proportional to the size of the change.
In otherwords, if it took some time (eg: more than 0.1 of a second)
to do something, this is unlikely.

(2) there's a bug in the resizer

(3) there's some linux cache issue, or something

None of these seem likely.  You said it looked like it did some
work, ruling out (1).  (2) is unlikely, because I haven't seen
a bug like this before.  I can't think of a scenario in LVM where
(3) might happen (nor can the LVM people... I asked on #lvm).

So, it's an Interesting problem.

Could you try changing something with other userland tools on
the fs, and seeing if it gets updated?  For example, change
the reserved blocks percentage with tune2fs -m.

        # umount blah
        # dumpe2fs blah > dump.before
        # tune2fs blah -m some-number
        # dumpe2fs blah > dump.after
        # diff -u dump.before dump.after


reply via email to

[Prev in Thread] Current Thread [Next in Thread]