[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

You found a bug in GNU Parted....

From: Vik Olliver
Subject: You found a bug in GNU Parted....
Date: 23 Jul 2002 12:48:09 +1200

Apparently I'm to mail you saying:

Version 1.6.2 and

Assertion (ptr->rec_len > 0) at
in function doblock() failed.

This is using the boot/root floppies to resize a /dev/hda2 partition on
an IDE disk in a laptop. The partition had been previously resized by
parted, but fsck and parted complained that the ext2 filesystem
(actually a RH7.3 ext3 partition) on hda2 was larger than the partition.

Being of inventive mind, I later manually enlarged the partition and ran
parted again with exactly the same error but no message indicating that
the filesystem exceeded the partition.

Going into the partition mounted ro seems to work, so it's not
completely scrambled. I did take a backup first, so I'm not concerned
about the state of the drive.

After this, I ran fsck on the partition and it passed with a heap of
"duplicate or bad block" errors only one of which hit a file.But alas,
the partition was fundamentally rooted.

I hope this is of some use to you, and not just a silly mistake that us
users make which causes a flurry of ignorable e-mail!

Vik :v)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]