[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

parted 1.6.4 bugs

From: Bob Ambrosius
Subject: parted 1.6.4 bugs
Date: Tue, 11 Mar 2003 19:19:28 +0100

I've been trying to install Parted version 1.6.4 as supplied by the magazine
Linux-Format (DVD LXF37) on my pentium based machine. It has the Suse 8.1
distribution installed. First my compliments for the excellent installation
scripts. Using it I got understandable errors, so I knew I had to install
some 'devel-' packages. The ./configure worked fine after that.

However, I got in 'make' the following error:
        aclocal.m4:141: version mismatch.  This is Automake 1.6.3, but 
        aclocal.m4:141: was generated for Automake 1.6.  You should recreate
        aclocal.m4:141: aclocal.m4 with aclocal and run automake again.
        WARNING: `automake-1.6' is needed, and you do not seem to have it handy 
                         system.  You might have modified some files without 
having the
                         proper tools for further handling them.  Check the 
`README' file,
                         it often tells you about the needed prerequirements 
for installing
                         this package.  You may also peek at any GNU archive 
site, in case
                         some other package would contain this missing 
`automake-1.6' program.
        make[3]: *** [Makefile.in] Error 1
        make[2]: *** [all-recursive] Error 1
        make[1]: *** [all-recursive] Error 1
        make: *** [all] Error 2

Then, doing a 'aclocal' I got:
        aclocal: configure.in: 185: macro `AM_GNU_GETTEXT' not found in library.

I solved it for now by changing the version number in line 141 from
aclocal.m4, but I have no idea of the consequences. After that the
installation went smoothly.

Another issue that mystifies me is that with 'print' the linux filesystem is
designated as 'ext3' (as it should be), but whith 'print <MINOR> I get the
message 'Warning: Filesystem was not cleanly unmounted!  You should e2fsck.'
And the file system is ext2!? I did a e2fsck from your boot floppy and the
partition was reported as clean. I read in the Info that this version of
parted could cope with ext3 file systems. Am I wrong?

I also found an error(?) in 'partprobe'. Using it with /dev/hda it reported
'segmentation fault'. Using it with /dev/hda6 (my linux ext3 partition) and
with the option -s, it gives no output.
My FSTAB is:
/dev/hda6            /                    ext3       defaults
1 1
/dev/hda7            /windat              vfat
user,gid=100,umask=0,iocharset=iso8859-15,codepage=437 0 0
/dev/hda1            /mnt/windows         ntfs       ro,user,gid=100,umask=0
0 0
/dev/hda5            swap                 swap       pri=42
0 0
devpts               /dev/pts             devpts     mode=0620,gid=5
0 0
proc                 /proc                proc       defaults
0 0
usbdevfs             /proc/bus/usb        usbdevfs   noauto
0 0
/dev/cdrom           /media/cdrom         auto       ro,noauto,user,exec
0 0
/dev/dvd             /media/dvd           auto       ro,noauto,user,exec
0 0
/dev/fd0             /media/floppy        auto       noauto,user,sync
0 0

I'd like to hear from you,
Bob Ambrosius
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.459 / Virus Database: 258 - Release Date: 25-2-03

reply via email to

[Prev in Thread] Current Thread [Next in Thread]