[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: extremely slow parted execution

From: Attila Tajti
Subject: Re: extremely slow parted execution
Date: Tue, 22 Apr 2003 17:25:21 +0200
User-agent: KMail/1.5.1

On Tuesday 2003 April 22 00:48, Andrew Clausen wrote:
> Sorry for the extremely late reply.

I beg your pardon, but due to this I can't remember at all what the problem 
and the solution was. :( 

> > I tried to resize a partition a 16G FAT32 on my Gentoo Linux system
> > (2.4.20-lolo-r2_pre5 kernel, Athlon 1.2GHz, 512M RAM, 80G UDMA 66 disk).
> > I tried to resize my last partition, which was 16G to free up 10G. It was
> > 10% full (~1.6G so 6G should be ok). Parted seem to be working with 100%
> > CPU utilisation, but I see only a short blink of the HDD led in every 3-4
> > seconds. dmesg contains only the line "invalidate: busy buffer" in it.
> That is very odd.  I don't really have any theories... could you run
> "strace parted", and tell me what operations are taking a long time?

I knew this was odd and most probably not a problem with parted.

Probably the lazy unmount caused this behavior, with the filesystem still 
being used by a process? As far as I can remember the problem was fixed after 
I tried to repartition my harddrive from another boot image. I tried the ones
on the parted page and the Gentoo Live CD.

> > It is still
> > running, but I think I'll have to abort the resize process. I backed up
> > my most important data anyway.
> It is safe to interrupt the resize process (except for a very small window
> at the very end).

I know. :)

Thank you,

Attila Tajti
Spacehawks, Inc

reply via email to

[Prev in Thread] Current Thread [Next in Thread]