[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

trying to recover data

From: Eliot Landrum
Subject: trying to recover data
Date: Sat, 26 Apr 2003 16:02:20 -0500
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4a) Gecko/20030303

Hello all..

I made a very stupid mistake last night and I'm trying to recover from it now. I'm hoping someone might have a bit of advice or at least a next step for me to take.

I wanted to resize some of my partitions around a little bit yesterday to install RH9 next to WinXP and Debian. But, something is off with my partitions and every single partition and disk tool I load complains about the same thing. Here's what parted says:

Warning: Unable to align partition properly. This probably means that another partitioning tool generated an incorrect partition table, because it didn't havethe correct BIOS geometry. It is safe to ignore,but ignoring may cause
(fixable) problems with some boot loaders.

Partition Magic had a similar error. I printed the partitions from parted:

Disk geometry for /dev/ide/host0/bus0/target0/lun0/disc: 0.000-38166.679 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031    125.507  primary   linux-swap
2        125.508   4180.979  primary   fat32       boot
3       4181.010  23853.000  primary   ext3
4      23854.329  38162.219  primary   fat32       lba
Information: Don't forget to update /etc/fstab, if necessary.

I thought maybe I could resize #4 to go to the very end (38166.679) and that might fix the alignment problem. Parted was happy to ablige, and seemed to resize it just fine.

Here's the stupid part. I forgot that my /incoming directory was a symlink to a directory on #4. So before rebooting, I copied a directory of mp3s from a friends computer to /incoming. Stupid. Stupid. Stupid. I'm banging my head against the wall over this.

So, I reboot and go to Windows. Low and behold, D: (#4) has one directory in it (the one I copied), but all 3247 items within it are named weird characters. I quickly loaded up PC Inspector File Recovery (http://www.pcinspector.de/file_recovery/UK/welcome.htm) and had it scan all of the clusters on the partition. After several minutes of scanning, it had a few thousand directories named "Cluster #" with my data in them! Apparently, the whole directory structure is gone. That's ok with me, as long as I could get my data back. I tried undeleting a file to another partition, but when I looked at the file it was full of random/weird characters. I tried several more with all of the same result. I've tried as many demo undelete programs for Windows as I could find, and they all give the same result. I'm really confused because the file names, the date stamps, and the file sizes are all correct.

I just now came back to Linux and ran parted again. It doesn't look like the partition has changed any. The printout is the same as before. I don't know the nitty-gritty about file systems, but I was thinking that the data is just not aligned right with the FAT. Maybe parted moved all of the data, but then the FAT got messed up when I copied those files to the partition. Is that close to reality?

So... what do I do next? Is there any hope? I really, really would like my files back. The good thing is that I haven't made any other changes to that partition. I just had data on there, so no programs are making changes to it as I go from Linux to Windows.

Thank you for any suggestions or guidance you can provide.

Have a great weekend!

Eliot Landrum

reply via email to

[Prev in Thread] Current Thread [Next in Thread]