[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: parted 1.6.11 assertion failure

From: Meelis Roos
Subject: Re: parted 1.6.11 assertion failure
Date: Fri, 24 Sep 2004 10:18:15 +0300 (EEST)

> > Error: Can't have a partition outside the disk!
> > A bug has been detected in GNU parted.  Please email a bug report to
> > address@hidden containing the version(1.6.11) and the following
> > message:Assertion (disk != NULL) at ../../libparted/disk.c:1037 in
> > function ped_disk_next_partition() failed.
> >
> > The background is that I really do have a partition bigger than the disk
> > (previous Linux kernels disabled host protected area, newer ones don't
> > so my extra 34M are gone from the end of the disk). I decided to fix the
> > partitions and got this warning while starting parted (qtparted frontend
> > actually). It still works, just gives the assertion failure.
> Does normal parted give the same error message?

I can't test any more, I repartitsioned the disk and it's in production

BTW, if there are both msdos and sun partition tables on the disk,
kernel and fdisk choose msdos partitions and parted chooses Sun
disklabel as I wanted. I understand this might be a general problem of 2
partition tables both existing on the disk, but maybe something can be
done to eliminate the other table when a new tables is created? I solved
the problem with dd if=/dev/zero by hand but it took some time to
understand what's happening. Maybe parted should at least give a warning
to the user when the creation of a disklable results in 2 disklabels
being valid at once.

Meelis Roos (address@hidden)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]