[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Problems with parted

From: David Ronis
Subject: Problems with parted
Date: Wed, 3 Nov 2004 21:43:25 -0500

I'm trying to shrink a partition on an HP Pavilion Zv5000 laptop.
I'm running slackware-10.0 with the kernel upgraded to 2.6.9.

I need to either increase the swap partition, or to shrink the size of
the second partition in order to create another swap partition (I want
to run the newest version of software-suspend).  From the
documentation, I don't think the former is possible.

I have 2 problems; first, this is the root partition I don't have a
floppy drive (just a CD).  I can create a CD boot disk, but wasn't
able to create a rootdisk; this has already been reported, and Andrew
suggested I try one of the rescue disks (Knoppix) that has parted.

Booting from the Knoppix disc and running parted fails

I tried 

parted /dev/hda

(parted) print                                                            
Disk geometry for /dev/hda: 0.000-57231.562 megabytes
Disk label type: msdos
Minor    Start       End     Type      Filesystem  Flags
1          0.031    133.352  primary   linux-swap  boot
2        133.352  57231.562  primary   ext3        

(parted) resize 2 133.352 56741.0

At which point it complains about the layout of this drive being
strange and not (yet) being able to resize.

I tried both the version that comes with Knoppix (1.6.9) and the most
recent 1.6.15 (copied from the disk to the ramdisk along with any
required libs etc) and both failed in the same way.

There is lots of space on this disk which is currently about 60%
empty, albeit tied up in /dev/hda2.

Any suggestions?  


Here's what fdisk /dev/hda -l gives:

Disk /dev/hda: 60.0 GB, 60011642880 bytes
255 heads, 63 sectors/track, 7296 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hda1   *           1          17      136521   82  Linux swap
/dev/hda2              18        7296    58468567+  83  Linux


Expert command (m for help): p

Disk /dev/hda: 255 heads, 63 sectors, 7296 cylinders

Nr AF  Hd Sec  Cyl  Hd Sec  Cyl     Start      Size ID
 1 80   1   1    0 254  63   16         63     273042 82
 2 00   0   1   17 254  63 1023     273105  116937135 83
 3 00   0   0    0   0   0    0          0          0 00
 4 00   0   0    0   0   0    0          0          0 00

I think the problem lies in a contradiction between these 2 tables.
The kernel is auto-detecting the disk geometry, which doesn't seem to
be manually settable from the BIOS in any event.

David Ronis                     Tel:  (514)398-5099
Department of Chemistry         Fax:  (514)398-3797
McGill University               E-mail:  address@hidden
801 Sherbrooke Street West      WWW: http://ronispc.chem.mcgill.ca/ronis
Montreal, Quebec

reply via email to

[Prev in Thread] Current Thread [Next in Thread]