[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: BLKPG changes pushed

From: Jim Meyering
Subject: Re: BLKPG changes pushed
Date: Sat, 24 Apr 2010 08:47:23 +0200

Phillip Susi wrote:
> On Fri, 2010-04-23 at 20:49 +0200, Jim Meyering wrote:
>> I'm not happy with these changes yet, mainly because of the lack of tests,
>> but also because I just tried to add a couple partitions (in free space),
>> and each time, I got this:
>>     $ sudo ./parted -s $dev u B mkpart F13-root $s2 $e2
>>     Warning: WARNING: the kernel failed to re-read the partition table on
>>     /dev/sda (Device or resource busy).  As a result, it may not reflect all
>>     of your changes until after reboot.
>> I thought the intent was to avoid such warnings when they do not apply.
>> The kernel was indeed notified of the creation of the two new
>> partitions, and I was able to create file systems on them.
> Indeed, it does not look like you have the patch applied since according
> to the last mail you send with the modification you made, it would be
> saying:

No.  That diagnostic comes from
_kernel_reread_part_table (PedDevice* dev)
        while (ioctl (arch_specific->fd, BLKRRPART)) {
                if (retry_count == 3)
                        sleep(1); /* Pause to allow system to settle */
                if (!retry_count) {
                        _("WARNING: the kernel failed to re-read the partition "

> "Partition(s) %s on %s have been written, but we have been unable to
> inform the kernel of the change, probably because it/they are in use.
> As a result, the old partition(s) will remain in use.  You should reboot
> now before making further changes."
> Maybe you ran the old binary instead of the one you just compiled by
> mistake?

No.  I'm certain that I ran the right binary.
Invoking "sudo ./parted ..." is not ambiguous.
Just didn't have time to debug it.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]