[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

compile probs w/ solaris 8

From: Amos Gouaux
Subject: compile probs w/ solaris 8
Date: Mon, 14 Jan 2002 14:47:29 -0600
User-agent: Gnus/5.090004 (Oort Gnus v0.04) XEmacs/21.4 (Common Lisp, sparc-sun-solaris2.8)


Sorry if this isn't appropriate place, but just got a request in
today to install gprolog for a class.  Sigh.

I've tried both gprolog-1.2.8 and gprolog-1.2.9 that I just found in
the "unstable" area.  With both I run into the following:

gplc -o pl2wam --no-fd-lib --min-bips pl2wam.o read_file.o bip_list.o 
syn_sugar.o internal.o code_gen.o reg_alloc.o inst_codif.o first_arg.o 
indexing.o wam_emit.o
gmake[1]: Leaving directory 
gmake[1]: Entering directory 
gplc -c --fast-math fd2c.pl

Fatal Error: Memory allocation fault
compilation failed
gmake[1]: *** [fd2c.o] Error 1
gmake[1]: Leaving directory 
gmake: *** [all] Error 1

I noticed the fairly recent post about EnginePl/Makefile.in
alteration for 1.2.8, but that didn't work.  Nor did 1.2.9.  I even
tried compiling with no optimization.  So far, no matter what I do I
still hit this spot.

So far I haven't found it anywhere, but is there a problem with
using gcc-3.0.3 to compile gprolog?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]