[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

can't build gprolog 1.4.5 on RHEL 7.5 x86-64 (regression)

From: Paul Eggert
Subject: can't build gprolog 1.4.5 on RHEL 7.5 x86-64 (regression)
Date: Wed, 31 Oct 2018 20:01:04 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.2.1

I recently tried to build gprolog 1.4.5 on RHEL 7.5 x86-64, and ran into 

First, downloading is painful. With previous releases I could issue a shell command like this:

wget https://ftp.gnu.org/gnu/gprolog/gprolog-1.4.4.tar.gz

But when I try that with 1.4.5, it doesn't work. Is there some reason gprolog is no longer being distributed via gnu.org?

I then visited <https://gprolog.org/> and Firefox said, "Your connection is not secure. The owner of gprolog.org has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website. gprolog.org uses an invalid security certificate. The certificate is only valid for the following names: *.univ-paris1.fr, trantor.univ-paris1.fr, univ-paris1.fr Error code: SSL_ERROR_BAD_CERT_DOMAIN". Could you please fix this? https: is becoming ssential nowadays.

So I backed off to <http://gprolog.org/>, and its Download section points to <http://gprolog.org/gprolog-1.4.5.tar.gz>. This command does work:

wget http://gprolog.org/gprolog-1.4.5.tar.gz

but it's http, not https, which is easily subject to man-in-the-middle attacks.

After downloading I could not build gprolog. I ran these commands:

tar xf gprolog-1.4.5.tar.gz
cd gprolog-1.4.5/src
./configure --prefix=/usr/local/cs/gprolog-1.4.5

This eventually failed as follows:

gplc -c wam_emit.wam
[ ! -f  pl2wam ] || cp pl2wam pl2wam0
gplc -o pl2wam --no-fd-lib-warn --no-top-level pl2wam.o read_file.o syn_sugar.o internal.o code_gen.o reg_alloc.o inst_codif.o first_arg.o indexing.o wam_emit.o
make[1]: Leaving directory `/dev/shm/eggert/gprolog-1.4.5/src/Pl2Wam'
make[1]: Entering directory `/dev/shm/eggert/gprolog-1.4.5/src/Fd2C'
gplc -c --fast-math fd2c.pl

Fatal Error: Segmentation Violation (bad address: 0x100ec814853)
compilation failed
make[1]: *** [fd2c.o] Error 1
make[1]: Leaving directory `/dev/shm/eggert/gprolog-1.4.5/src/Fd2C'
make: *** [all] Error 1

I went back to gprolog 1.4.4 and it downloaded and built without trouble.

My RHEL 7.5 platform has kernel 3.10.0-862.14.4.el7.x86_64 and gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-28). The CPU is an Intel Xeon E5-2640 v2.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]