[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: localisation of 'info' not working

From: Oleg Katsitadze
Subject: Re: localisation of 'info' not working
Date: Fri, 30 Nov 2007 10:57:31 +0200
User-agent: Mutt/1.5.17 (2007-11-01)

On Wed, Nov 28, 2007 at 07:37:44PM -0600, Karl Berry wrote:
> Sergey, Oleg, anyone, maybe info xmlwf (or something) has multibyte
> character breakage (see url above) in, say, a Cyrillic UTF-8 locale?

I couldn't find a Russian man page for xmlwf, so I just tried other
man pages.  I'm on Debian with

  $ info --version
  info (GNU texinfo) 4.8

  $ apt-cache show manpages | grep Version
  Version: 2.67-1

  $ apt-cache show manpages-ru | grep Version
  Version: 0.98-4

My settings are

  $ env | grep 'LC_\|LANG'

I could not detect the "breaking a line in the middle of a multibyte
character" bug in any man pages I've tried (about a dozen), but there
_is_ excessive whitespace between the search prompt and the input
field (see the attached screenshot).  Other problems I've noticed:

Section headings are always garbled.

There's some garbage (bits of text from the end of the man page) in
the first section (NAME) -- gets fixed with C-l.  Such garbage from
another part of a man page seems to appear after C-v or M-v.

After C-v or M-v, a random char gets garbled (_not_ some text from
other parts, just a random char, e.g., ½), but after I press C-l, the
char gets corrected.

Also notice in the attached screenshot that with incremental search,
the cursor is moved beyond the found text.  It seems that info counts
two char cells for every Cyrillic char (Cyrillic UTF-8 chars are two
bytes) -- the cursor position is correct when there are no preceding
Cyrillic chars on a line, and the more of them there, the bigger the
offset.  (This also explains the search prompt bug and that EOL's are
way beyond visual line endings in case of lines with Cyrillic chars).

BTW, I couldn't do incremental search on Cyrillic text at all -- the
screen just flashes (visual bell) and info displays a message about an
unknown M-<whatever> key combination.


Attachment: info-l10n.png
Description: PNG image

reply via email to

[Prev in Thread] Current Thread [Next in Thread]