[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: weird @include problem under Cygwin

From: Per Bothner
Subject: Re: weird @include problem under Cygwin
Date: Fri, 23 Jan 2015 13:23:54 -0800
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Thunderbird/31.4.0

On 1/20/2015 1:06 PM, Per Bothner wrote:
I'm testing building Kawa (including kawa.info) using Cygwin, and
ran into this puzzling problem:

$ makeinfo -I . -o kawa.info kawa.texi
kawa.texi:123: @include: could not find version.texi
kawa.texi:130: warning: undefined flag: UPDATED

It looks like some strange permission problem - it went away when I did:
  chmod +r *.texi
and now I can't reproduce it.

(I first tried creating a tar file, but that seems to have papered over the
permission problem.)

What was strange was makeinfo could read version.texi when invoked directly
in version.texi, but not when trying to @include version.texi.  Is it possible
makeinfo opens opens a file using a different incantation when reading for
include as opposed to when opening the input file on the command line?

While I can't reproduce the problem now, my guess at this point is some 
(inconsistency) between MinGW and Cygwin and how they handle permissions:  I had
tried to run make info first on MinGW and then later uses Cygwin, on the same
same subversion-checked-out directory.  (Using MinGW failed because the MinGW
version of makeinfo is 4.13, and I make use of some 5.x features.  However, the
MinGW version of makeinfo did create the problematic version.texi.)

On 01/21/2015 06:54 PM, Ken Brown wrote:
I've done it without a problem, on both 32-bit and 64-bit Cygwin.  Can you send 
a minimal example that fails for you?

Thanks.  At this point there doesn't seem to be much to do.  Except perhaps 
make sure
that the code for opening a file from the command line and for @include use the
same logic to the extent possible, to avoid such anomalies,
        --Per Bothner
address@hidden   http://per.bothner.com/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]