[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: problem with texi2dvi from texinfo 6.1

From: Gavin Smith
Subject: Re: problem with texi2dvi from texinfo 6.1
Date: Mon, 22 Feb 2016 18:16:19 +0000

On 22 February 2016 at 18:00, Kurt Hornik <address@hidden> wrote:
> Sure.
> I get
> $ ls Rd2.*
> Rd2.tex
> $ ./texi2dvi --verbose Rd2.tex >/dev/null
> ./texi2dvi: Processing Rd2.tex ...
> ./texi2dvi: Checking TeX \openout in log support...
> ./texi2dvi: ./texi2dvi: running latex --file-line-error '\input' 
> ./openout.tex ...
> ./texi2dvi: Checking TeX \openout in log support... no
> ./texi2dvi: Checking TeX recorder support...
> ./texi2dvi: ./texi2dvi: running latex --file-line-error -recorder '\input' 
> ./openout.tex ...
> ./texi2dvi: Checking TeX recorder support... yes

> I seem to get a .fls file and you don't, perhaps that explains the
> difference?
> Best
> -k

It most likely does, although I don't see how it could have worked for
you before, because the support for looking in the *.fls file is new,
and according to the check:

./texi2dvi: Checking TeX \openout in log support... no

searching for \openout in the log files doesn't work for your version
of TeX. Unless the check is wrong and openout does appear in the log
files, maybe with a different format to what is expected?

Please send the *.log file and I'll look through it for what the
\openout lines look like if they are there.

I tried using the debugging option:

 TEXI2DVI_USE_RECORDER=yes ./texi2dvi --verbose Rd2.tex >/dev/null

and still failed to make it break. The recorder file, "Rd2.fls", does
have the "Rd2.out" file as required:

$ cat Rd2.fls | grep OUTPUT
OUTPUT Rd2.log
OUTPUT Rd2.idx
OUTPUT Rd2.aux
OUTPUT Rd2.out
OUTPUT Rd2.dvi
OUTPUT Rd2.toc

Please have a look at the Rd2.fls file and see if that line is there.

As a workaround, you could also try

TEXI2DVI_USE_RECORDER=no ./texi2dvi Rd2.tex

and see if that works: the test for whether the \openout lines appear
could be failing and this should bypass the test.

> $ ./texi2dvi --version
> texi2dvi (GNU Texinfo 6.0+dev) 6637

Don't understand why it isn't texi2dvi 6.1. Oh, I see, that was the
commit where it broke.

$ tar xf texinfo-6.1.tar.xz
$ cd texinfo-6.1/util
$ ./texi2dvi --version
texi2dvi (GNU Texinfo 6.1) 6991

Copyright (C) 2016 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]