[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: regression: ESS cannot be compiled

From: Martin Maechler
Subject: Re: regression: ESS cannot be compiled
Date: Fri, 4 Mar 2016 11:38:41 +0100

>>>>> Norbert Preining <address@hidden>
>>>>>     on Fri, 4 Mar 2016 13:01:23 +0900 writes:

    > Dear all,
    > down here at Debian we got another bug report about a FTBFS, which
    > went away when switching to an older version of texinfo.tex:

    > On Thu, 03 Mar 2016, Dirk Eddelbuettel wrote:
    >> Ok, the obvious fix of fattening the source directory with a working 
copy of
    >> texinfo.tex did the trick.

    > I have reduced the problematic case to the following minimal example:

    > \input texinfo   @c -*-texinfo-*-
    > @setfilename ess.info
    > @settitle ESS -- Emacs Speaks Statistics

    > @macro ESS{ARG}
    > @acronym{ESS\ARG\}
    > @end macro

    > @ESS{}: bad

    > @ESS{[R]}: good

    > @bye

    > The output is:
    > ./bla.texi:9: Argument of @gobblespaces has an extra }.
    > <inserted text> 
    > @par 
    > <to be read again> 
    > }
    > @doacronym address@hidden ->address@hidden @lsize #1}
    > @def @temp address@hidden @temp ...
    > l.1 @address@hidden }
    > @texinfoc
    > @scanmacro ...atspaces address@hidden address@hidden }
    > @aftermacro 
    > l.9 @ESS{}
    > : bad
    > ? 

    > Can anyone comment on this?


- This macro use has always worked in the ESS sources for
  around 20 years maybe.
- It still works for me (with a TeX Live 2015 version of texinfo.tex
  that declares  'Loading texinfo [version 2015-07-01.07]'

>From these two facts I'd declare that the new texinfo.tex that
you have in Debian is broken.
(Yes, that is a strong statement; but still breaking something
 that worked dozens of year w/o problems needs VERY good arguments
 before you can call it "progress" !!)

Attachment: ess-tst.texi
Description: Binary data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]