[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[bug #47566] Loosing LocalData with texi2any

From: Vincent Belaïche
Subject: [bug #47566] Loosing LocalData with texi2any
Date: Tue, 29 Mar 2016 18:33:02 +0000
User-agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0


                 Summary: Loosing LocalData with texi2any
                 Project: texinfo - GNU documentation system
            Submitted by: vincentb1
            Submitted on: mar. 29 mars 2016 18:33:01 GMT
                Category: makeinfo
                Priority: 5 - Normal
                Severity: 3 - Normal
              Item Group: bug
                 Privacy: Public
             Open/Closed: Open
             Assigned to: None
         Discussion Lock: Any
                  Status: None



= Loosing LocalData with uninstalled version =

Currently to run texi2any on MSWindows I am using an ``uninstalled'' SVN
version. That is to say I have a wrapper that just calls the texi2any
script from the SVN work area using the activestate perl.

FYI, the source of this wrapper is attached as makeinfo-dos.cpp.

Please note that I need the activestate perl because if I use the MSYS
perl in the wrapper, then I get the following error message when
compiling latex2e-fr.texi from latexrefman GNA! project:

Use of uninitialized value in lc at /usr/lib/perl5/5.8/utf8_heavy.pl line

Now the problem I have is that using this non-installed version lacks
the LocalData. The implication is that compiling latex2e-fr.texi from
latexrefman GNA! project this way will make ``Table of contents''
instead of ``Table des matières''.

Please note that lacking the LocalData is is true whether I use the
activestate of the MSYS perl with my wrapper, the root cause seems that
I am using an uninstalled version.

Please also note that I get this error message on any compilation:

Locales dir for document strings not found
(C:\Programmes\installation\texinfo-install\trunk\tp\LocaleData LocaleData
..\..\..\tp\LocaleData ..\..\tp\LocaleData)

Here is the command line which I use:

-o "c:/Nos_Programmes/MinGW/msys/share/info/latex2e-fr.info"

= Unable to install texi2any =

So, why using an ``uninstalled'' version. Well, the thing is that trying
as much as I could, I never could install texi2any.

When trying to install texi2any on MSWindows with MSYS and with MSYS
configured to use the MSYS perl (eg by having the fstab file having /perl
directory pointing that the MSYS perl), then I get the following error

WARNING: BUILD_REQUIRES is not a known parameter.
'BUILD_REQUIRES' is not a known MakeMaker parameter name.
ERROR from evaluation of
Perl v5.18.1 required--this is only v5.8.8, stopped at ./Makefile.PL line 1.
BEGIN failed--compilation aborted at ./Makefile.PL line 1.

Now, if I change the MSYS fstab file so that the perl is activestate
perl, then installation of texi2any will make this error:

ERROR from evaluation of
Could not open 'XSParagraph.pm': No such file or directory at
c:/Programmes/Perl64/lib/ExtUtils/MM_Unix.pm line 2781, <$fh> line 90.

Please note that configure was called as follows:

./configure --disable-perl-xs

Please note also that automake utility does not work when activestate
perl is used instead of MSYS perl, I get this error:

Can't locate Automake/Config.pm in @INC (you may need to install the
Automake::Config module) (@INC contains: /usr/local/share/automake-1.15
c:/Programmes/Perl64/site/lib c:/Programmes/Perl64/lib .) at
c:/Nos_Programmes/MinGW/local/bin/automake line 48.
BEGIN failed--compilation aborted at
c:/Nos_Programmes/MinGW/local/bin/automake line 48.

I have tried to hack this by giving the MSWindows path of automake to
activestate perl, ie I did:

export PERL5LIB=c:/Nos_Programmes/MinGW/local/share/automake-1.15

and then I tried automake again, and here is the error it makes (well it
is not really surprising that the MSYS automake does not work with

Unescaped left brace in regex is deprecated, passed through in regex; marked
by <-- HERE in m/\${ <-- HERE ([^ \t=:+{}]+)}/ at
c:/Nos_Programmes/MinGW/local/bin/automake line 3936.
'autoconf' n'est pas reconnu en tant que commande interne
ou externe, un programme ex‚cutable ou un fichier de commandes.
POSIX::WIFEXITED not implemented on this architecture at
c:/Nos_Programmes/MinGW/local/share/automake-1.15/Automake/FileUtils.pm line


File Attachments:

Date: mar. 29 mars 2016 18:33:01 GMT  Name: makeinfo-dos.cpp  Size: 3 ko   By:



Reply to this item at:


  Message posté via/par Savannah

reply via email to

[Prev in Thread] Current Thread [Next in Thread]