[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [bug #47566] Loosing LocalData with texi2any

From: Vincent Belaïche
Subject: Re: [bug #47566] Loosing LocalData with texi2any
Date: Wed, 30 Mar 2016 18:16:23 +0200

Answers below:

Le 30/03/2016 18:07, Gavin Smith a écrit :
> On 30 March 2016 at 11:16, Vincent Belaïche <address@hidden> wrote:
>>> Have you run "make" to generate the content of this directory? (Not
>>> "make install".)
>> I have tried make from the trunk directory. Anyway, if I use the
>> activestate perl, then the auto-tools won't work, and running make in
>> the tp directory gives this:
>> --8<----8<----8<----8<----8<-- begin -->8---->8---->8---->8---->8----
>> address@hidden /c/Programmes/installation/texinfo-install/trunk/tp
>> $ make
>>  cd .. && /bin/sh 
>> /c/Programmes/installation/texinfo-install/trunk/build-aux/missing 
>> automake-1.15 --gnu tp/Makefile
>> Unescaped left brace in regex is deprecated, passed through in regex; marked 
>> by <-- HERE in m/\${ <-- HERE ([^ \t=:+{}]+)}/ at 
>> c:/Nos_Programmes/MinGW/local/bin/automake-1.15 line 3936.
>> 'autoconf' n'est pas reconnu en tant que commande interne
>> ou externe, un programme ex‚cutable ou un fichier de commandes.
>> POSIX::WIFEXITED not implemented on this architecture at 
>> c:/Nos_Programmes/MinGW/local/share/automake-1.15/Automake/FileUtils.pm line 
>> 241.
>> make: *** [Makefile.in] Error 1
>> --8<----8<----8<----8<----8<--  end  -->8---->8---->8---->8---->8----
> It's saying that autoconf isn't known as a command. Do you have
> autoconf and automake installed?

Sorry, I should not have confused you with this. It is not surprising
that it says that autoconf is not known because this is the attempt with
MSYS configured to use activestate perl, not the MSYS perl. So autoconf
cannot be found when it is called _from a perl script_, even though it
is in the *MSYS* PATH, because activestate perl does no know the MSYS
PATH but only the MSW PATH.

> Have you tried a released version at ftp://ftp.gnu.org/gnu/texinfo
> which doesn't need autoconf or automake?

I have autoconf and automake installed, but they can be invoked only
from MSYS, as soon as you go into some MSW native stuff, they cannot be
any longer called from there.

Please have a look at the following log in my previous email where I
call make with MSYS configured to use the MSYS, not activestate,
perl. Then the log is quite longer, and it fails because for some reason
some`t-ca.us-ascii.gmo' file has not been created during the build.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]