[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

install-info --remove Leaves "dir" Unmodified

From: Paul Hardy
Subject: install-info --remove Leaves "dir" Unmodified
Date: Wed, 11 Jul 2018 20:16:55 -0700

I looked at message subjects on this list from the past two years but
this does not seem to have been reported before.

After successfully installing a Texinfo page in /usr/local/share/info
with install-info, with the "dir" info directory file in that
directory correctly updated, an "install-info --remove" command fails.
The info file is removed but the "dir" file is not updated to remove
that selection.

The relevant "make uninstall" command that automake 1.16.1 generates
and runs is:

     install-info --info-dir='/usr/local/share/info' --remove

This happens under Debian 9 ("stretch") GNU/Linux with the latest
stable patches, FreeBSD 11.2, and Mac OS X.  I also tried various
other permutations on "install-info" on the command line, such as
explicitly specifying a section for the "install-info --remove"
command.  Nothing I tried updated the "dir" file.

I am using install-info version 6.5 from the latest "texinfo" package
sources.  Is there some way of updating the info directory file that
automake and I can both change to so this succeeds?

Please CC me on replies as I do not subscribe to this list.

Thank you,

Paul Hardy

reply via email to

[Prev in Thread] Current Thread [Next in Thread]