[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

texi2dvi error on -recoder and \openout

From: Mohammad Akhlaghi
Subject: texi2dvi error on -recoder and \openout
Date: Thu, 20 Sep 2018 17:48:19 +0200
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.0


Today when I tried to build the PDF version of Gnuastro's manual (with `make pdf'), I confronted the following error:

make[1]: Entering directory '/home/myid/work/tmp/gnuastro-0.7/doc'
TEXINPUTS="../bootstrapped/build-aux:$TEXINPUTS" \
MAKEINFO='/bin/bash /home/myid/work/tmp/gnuastro-0.7/bootstrapped/build-aux/missing makeinfo -I ../bootstrapped/doc -I . -I .' \ texi2dvi -I ../bootstrapped/doc -I . --pdf --batch --build-dir=gnuastro.t2p -o gnuastro.pdf \
/usr/bin/texi2dvi: TeX neither supports -recorder nor outputs \openout lines in its log file
make[1]: *** [Makefile:1750: gnuastro.pdf] Error 1
make[1]: Leaving directory '/home/myid/work/tmp/gnuastro-0.7/doc'
make: *** [Makefile:1833: pdf-recursive] Error 1

Texi2dvi is from Texinfo version 6.5 (2017).

This problem can be reproduced with the Gnuastro tarball:
But I also tried it on GAWK's tarball (which has fewer dependencies and is easier to check/reproduce), and the problem comes up there too:

I build PDF manuals regularly, the only related thing that might have affected this is that I ran `tlmgr update --all' recently and something related to DVI was updated. But I don't know how to get the history of installed packages with `tlmgr' to check what it was. If it is relevant, could you please give me the necessary command to check?

Thank you very much,

reply via email to

[Prev in Thread] Current Thread [Next in Thread]