[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Build error (no nls)

From: Gavin Smith
Subject: Re: Build error (no nls)
Date: Sat, 28 Aug 2021 21:03:46 +0100
User-agent: Mutt/1.9.4 (2018-02-28)

On Fri, Aug 20, 2021 at 01:51:37PM -0400, shoober420 wrote:
> I'm getting a build error when compiling from latest git master as of this
> email (
> https://git.savannah.gnu.org/cgit/texinfo.git/commit/?id=05261ac09977c25e22a1c58955e11c0041cb3e4d).
> Im using Gentoo Linux and GCC 11.2 version. full log attached.

I don't know if you still have this problem but I don't see anything in that
commit that could have caused this problem.  It's hard to track down
any problem from this email as I'm not familiar with Gentoo builds.  I tried
the configure invocation from your log (please don't send logs with escape
sequences in them if you can avoid it as it's harder to read).

 ./configure --prefix=/usr --build=x86_64-pc-linux-gnu 
--host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info 
--datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib 
--disable-dependency-tracking --disable-silent-rules 
--docdir=/usr/share/doc/texinfo-9999 --htmldir=/usr/share/doc/texinfo-9999/html 
--libdir=/usr/lib64 --disable-nls --without-external-libintl-perl 
--without-external-Unicode-EastAsianWidth --without-external-Text-Unidecode 

(The build and host options were appropriate for my machine.)

I then ran "make clean" and "make".  Finally, tried

rm po_document/texinfo_document.pot 
rm po_document/*.gmo

and make again, which worked.  Also "make texinfo_document.pot-update".

You have an error in your log

> mv: cannot stat 't-remove-potcdate.sed': No such file or directory

I don't have anything in my po_document directory that has anything
to do with this file so it's hard for me to see the problem.  I wonder
if it is to do with different gettext versions.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]