[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Missing AWT peer

From: Andreas Rueckert
Subject: Re: Missing AWT peer
Date: Wed, 17 Oct 2001 15:22:33 +0200


On Mit, 17 Okt 2001 Bryce McKinlay wrote:
> Andreas Rueckert wrote:
> >>Not necessarily.  Any paths seen by ld (e.g. with -L) will not be
> >>automatically searched by the loader (assuming an ELF target).
> >>
> >>So each lib directory must be one of the "system" lib dirs or mentioned in
> >>LD_LIBRARY_PATH, unless you also link with -rpath.
> >>
> >
> >All these libs are in /etc/ , so it should work. 
> >
> Nope. The path to the libraries must be in LD_LIBRARY_PATH. I believe 
> this is a limitation of dlopen or maybe libtool's ltdl.

Ok, I set the LD_LIBRARY_PATH var. Same result.

> >Is there any way to
> >get additional info what lib is missing?
> >
> Classpath's reference runtime implementation should throw the missing 
> library name with the UnsatisfiedLinkError. For some reason your stack 
> trace didnt mention it. Which VM is this?

ORP 1.0.6

> >I honestly think that Classpath is ridiculously complex to install. I guess
> >you're doing a great job, but as it is, noone will notice. Have you ever
> >thought of creating RPMs for popular Linux distros, or so?
> >
> Here is the build procedure I use to get a classpath suitable for use 
> with ORP:
> 1. create gnu/classpath/ by hand, from 
> gnu/classpath/
> 2. mkdir build
> 3. javac -d build -classpath .:build `find java gnu vm -name "*.java"`
> 4. cp gnu/java/locale/*.uni build/gnu/java/locale/
> 5. cp gnu/java/locale/*.properties build/gnu/java/locale/
> I admit that this doesn't help if you want the native libraries, 
> however. The lack of an easy-to-use configure/build is a known problem, 
> and we'd love it if someone were to help fix it.

Console apps seem to work. At a HelloWorldApp worked as expected. It seems that
it's just a problem with the GTK lib.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]