classpath
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: SpringLayout


From: Roman Kennke
Subject: Re: SpringLayout
Date: Fri, 04 Jun 2004 20:43:24 +0200

> Here are my comments:
> 
> +    public ImageIcon(Image image) {
> 
> Please put '{' on new line

a habit of mine, sorry,

> +        return;
> 
> No need for this.

another habit of mine.

> +package javax.swing;
> +
> +/**
> + * DOCUMENT ME!
> 
> Please add dcoumentation from the beginning. Otherwise it will never 
> be written ....

That's right. For most of the stuff it would make sense to copy+paste
the 'official' documentation. Is that allowed (I suppose not).

> +class SimpleSpring extends Spring
> 
> You can make this an inner class. Thats IMO better.

yeah, I tried this, but the compiler didn't want it, because of the
constructor of Spring, which is not accessible from an inner class. I
think I play with this a bit (maybe static inner class?)

> +    private int min, pref, max, value;
> 
> One line for each variable (probably with documentation) is better.

That's right. That's _no_ habit of mine, normally.

> +      int max1 = s1.getMaximumValue();
> +      int max2 = s2.getMaximumValue();
> +      return max1 + max2;
> 
> Why not "return s1.getMaximumValue() + s2.getMaximumValue();" ?

Don't know. ;-) I normally think it's more readable to have less things
on one line.

> +                  if ((retVal == null) && (y != null) && (height !=
>  null))
> 
> Its more readable when each condition is on a new line with the 
> connecting operator on front of the line.

That's right. My opinion (see  previous comment).

> Thanks, for your work. I have only checked this for style now. I think 
> you get the ideas of the my style hints.

Yes. Thank you for checking.

Cheers,
Roman

Attachment: signature.asc
Description: Dies ist ein digital signierter Nachrichtenteil


reply via email to

[Prev in Thread] Current Thread [Next in Thread]