[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [patch] spurious fails with rsh target

From: Daniel Jacobowitz
Subject: Re: [patch] spurious fails with rsh target
Date: Thu, 27 Jan 2005 23:30:16 -0500
User-agent: Mutt/

On Mon, Jan 24, 2005 at 01:47:28PM -0800, Felix Lee wrote:
> symptom: when using rsh to talk to a target board, I get dozens
> of FAILs and UNRESOLVEDs because of failure to send program to
> target, failure to execute command on target, etc.  runtest -v,
> the error message from rsh is something like "rcmd: socket: All
> ports in use".
> what happens is rsh wants to allocate a "privileged" port<1024 on
> the local machine, and the tcp protocol requires a port to stay
> allocated for 2min after the connection is closed, and the target
> machine is fast enough that hundreds of rsh and rcp happen in
> less than 2min, so I run out of unallocated ports<1024.
> one workaround is to use ssh instead of rsh, since ssh will use
> ports>=1024.
> another workaround is to retry the rsh a couple times before
> giving up, which is the patch below.
> it might be nice if rsh.exp tried to use a persistent rsh
> connection, but that's a bigger change, and it will still need to
> retry sometimes.

This patch means you're going to run failing tests five times...
FWIW, I've never had the problem you describe when testing with RSH;
I can't remember exactly how, but you can configure most systems to
reuse more quickly and in practice it causes no harm.

[I actually have a whole bunch of rsh.exp patches I've been meaning to
post, including timeout support.  I haven't had time to sort them out
of my working tree yet.  Bug me if you need them, anybody.]

Daniel Jacobowitz

reply via email to

[Prev in Thread] Current Thread [Next in Thread]