[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

address@hidden: Re: A new pretest]

From: Richard Stallman
Subject: address@hidden: Re: A new pretest]
Date: Sun, 13 Oct 2002 18:48:29 -0400

Can someone investigate this X bug in the RC branch?

------- Start of forwarded message -------
Envelope-to: address@hidden
Delivery-date: Sat, 12 Oct 2002 13:17:43 -0400
Date: Sat, 12 Oct 2002 12:17:38 -0500 (CDT)
From: "David R. Linn" <address@hidden>
Reply-To: "David R. Linn" <address@hidden>
Subject: Re: A new pretest
To: address@hidden
Content-MD5: pVOlfw/63ZDQWq149/qsZw==
X-Spam-Status: No, hits=-2.9 required=5.0

>> There is a new pretest available in
>>   <ftp://alpha.gnu.org/gnu/emacs/pretest/emacs-21.2.91.tar.gz>
>>   <ftp://alpha.gnu.org/gnu/emacs/pretest/leim-21.2.91.tar.gz>

Sorry about that last useless message - I clicked "send" when I meant to
click "delete".

Anyway, ... 
Under SunOS 5.9/Solaris 9 on SUN Ultra 5 (SPARC v9) with SunPro/Forte C
v6.0 and otherwise standard Solaris 9 tools/libs, I had no errors or
unexpected warnings building emacs v21.2.91.

However, installation failed because I do not (yet) have makeinfo on
this box.
- -----
(cd man; make  info)
cd /ufs/sys2/FSF/Emacs/21/91/emacs-21.2.91/man; makeinfo emacs.texi
sh: makeinfo: not found
*** Error code 1
make: Fatal error: Command failed for target `../info/emacs'
Current working directory /ufs/sys2/FSF/Emacs/21/91/s9/man
*** Error code 1
make: Fatal error: Command failed for target `info'
- -----

I'd like to suggest that we either ship the results of makeinfo in
the tarball or test for the presence of makeinfo in configure and
skip this step if makeinfo is not found.

In order to route around this problem, I put a symlink in ${HOME}/bin
from 'makeinfo' to '/bin/true' which allowed me to "complete" the 
installation process.

Execution of tty emacs (actually in a CDE dtterm with '-nw') worked
fine and more testing of new stuff will take place later.

Execution of X emacs (using the XWS DISPLAY directly) failed badly.
I got a window with a medium tan area above a medium purple area
(the latter is the default background color for CDE on Solaris9)
with no text, no graphics, and no keyboard or mouse capability.
The mouse cursor *did* change to the up-right-pointing arrow when
it went into what *should* have be the toolbar and reverted to the
vertical "i-beam" cursor when it was returned to what should have
been the normal text area.  I was unable to kill this (X) window
via keyboard or mouse (not even by trying the "Close/Alt-F4 action
in the window manager title bar) - I had to resort to sending
an interrupt via the parent shell's tty window.

I tried this again with the --no-init-file flag but that made no

Checking my build area, it appears I never actually built emacs v21.2.90
so these problems may not be new.

Obviously, debugging is needed but I'm not much of an X programmer.
What do I need to do next?
------- End of forwarded message -------

reply via email to

[Prev in Thread] Current Thread [Next in Thread]