[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

no font shown with tamil.el

From: Robert J. Chassell
Subject: no font shown with tamil.el
Date: Tue, 11 Feb 2003 18:01:09 +0000 (UTC)

The HELLO buffer no longer shows Hindi and does not show Tamil fonts.
Emacs shows empty boxes.

An instance of GNU Emacs 20.7 shows Hindi fonts.

      Debian `testing' distribution, updated today.

      Today's CVS snapshot, Tue, 2003 Feb 11  17:29 UTC
      GNU Emacs (i686-pc-linux-gnu, X toolkit)
      started with

         /usr/local/bin/emacs -q --no-site-file --eval '(blink-cursor-mode 0)'

Following the instructions in the NEWS file:

    See the INSTALL file for information on installing extra libraries
    and fonts to take advantage of the new graphical features and
    extra charsets in this release.

I looked for the intlfonts distribution, which can be obtained by FTP
from ftp.gnu.org.  However, I already have the latest intlfonts
version, 1.2; and besides the NEWS file also says:

    ** Leim is now part of the Emacs distribution.
    You no longer need to download a separate tarball in order to build
    Emacs with Leim.

Also, I tried commenting out the contents of tamil.el, and rebuilding
with a `make bootstrap' command rather than a `make recompile'
command, but that did not restore the fonts.

On running `C-u C-x =' (what-cursor-position with a prefix arg)
on the first of the Tamil characters in the HELLO buffer:

Tamil ($,1<D<N<_<T<m(B)               $,1<U<C<5<m<5<N<m(B

where the non-Latin characters in the above line are empty boxes, 

I see, where the non-Latin character after the colon on the first line
below is also an empty box:

    character: $,1<D(B (01217104, 335428, 0x51e44)
      charset: mule-unicode-0100-24ff
               (Unicode characters of the range U+0100..U+24FF.)
   code point: 60 68
       syntax: w        which means: word
  buffer code: 0x9C 0xF4 0xBC 0xC4
    file code: ESC 24 2C 31 3C 44 (encoded by coding system iso-2022-7bit-unix)
      Unicode: 0BA4
         font: -ETL-Fixed-Medium-R-Normal--16-160-72-72-C-80-ISO10646-1

  Composed with the following character(s) `' to form `$,1<D(B'
  by the rule (?$,4*N(B).
  See the variable `reference-point-alist' for the meaning of the rule.

  There are text properties here:
    composition          (11 1

I tried various fonts and fontsets using the `mouse-set-font'
(SHIFT-mouse-1) command; the empty boxes remained.

Finally, I tried setting the coding system with the command

    set-buffer-file-coding-system   (C-x RET f)

both to utf-8 and to iso-2022-7bit; neither had any effect.

In my /etc/X11/XF86Config-4, I have the following:

  Section "Files"

          # Uncommenting the "unix/:7100" line leads to wider default fonts
          FontPath      "unix/:7100"    # for xfs, but xfs-xtt is newer
          FontPath      "unix/:7101"    # for xfs-xtt -- load both

          # If the local font server has problems, we can fall back on these
          FontPath      "/usr/lib/X11/fonts/Type1"
          FontPath      "/usr/lib/X11/fonts/Speedo"
          FontPath      "/usr/lib/X11/fonts/100dpi"
          FontPath      "/usr/lib/X11/fonts/75dpi"
          FontPath      "/usr/local/share/emacs/fonts/"
          FontPath      "/usr/local/share/emacs/fonts/bdf"
          FontPath      "/usr/local/src/intlfonts/European"
          FontPath      "/usr/lib/X11/fonts/misc"
          FontPath      "/usr/lib/X11/fonts/cyrillic"

What should I do?

    Robert J. Chassell                         Rattlesnake Enterprises
    http://www.rattlesnake.com                  GnuPG Key ID: 004B4AC8
    http://www.teak.cc                             address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]