[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

address@hidden: Emacs (from CVS): compilation failure: DOC requires *.el

From: Richard Stallman
Subject: address@hidden: Emacs (from CVS): compilation failure: DOC requires *.elc files which have not yet been generated]
Date: Sat, 05 Apr 2003 21:00:01 -0500

Can someone try fixing this?

------- Start of forwarded message -------
From: Steven Augart <address@hidden>
To: address@hidden
Date: Thu,  3 Apr 2003 16:07:57 -0800 (PST)
Subject: Emacs (from CVS): compilation failure: DOC requires *.elc files
 which have not yet been generated
Sender: address@hidden

Dear Emacs Pretest Bug list,

I am building emacs from CVS source.  I most recently ran CVS Update at
April 3rd 2003, 23:30 GMT.  

As recommended in INSTALL-CVS, I ran "configure", then "make
bootstrap".  (I have tried this twice.)  I get this output from "make":

  nice make -w
  make: Entering directory `/spare/src/Emacs21/emacs-CVS'
  make[1]: Entering directory `/spare/src/Emacs21/emacs-CVS/src'
  cd ../lwlib/; make -w CC='gcc' CFLAGS='-std=gnu9x -D_FILE_OFFSET_BITS=64 
-pipe -ggdb3 -W -Wall -Wbad-function-cast -Wcast-align -Wpointer-arith 
-Wcast-qual -Wshadow -Wstrict-prototypes -Wmissing-prototypes 
-Wmissing-declarations -fkeep-static-consts  -fkeep-inline-functions -Wundef 
-Wwrite-strings -Waggregate-return -Wmissing-noreturn -Wnested-externs 
-Wtrigraphs' MAKE='make' "C_SWITCH_X_SITE=-I/usr/X11R6/include" 
  make[2]: Entering directory `/spare/src/Emacs21/emacs-CVS/lwlib'
  make[2]: Nothing to be done for `all'.
  make[2]: Leaving directory `/spare/src/Emacs21/emacs-CVS/lwlib'
  make[1]: *** No rule to make target 
`/usr/src/Emacs21/emacs-CVS/src/../lisp/map-ynp.elc', needed by `../etc/DOC'.  
  make[1]: Leaving directory `/spare/src/Emacs21/emacs-CVS/src'
  make: *** [src] Error 2
  make: Leaving directory `/spare/src/Emacs21/emacs-CVS'

  Compilation exited abnormally with code 2 at Thu Apr  3 15:42:16

In src/Makefile, I find the following dependency:

   ${etc}DOC: ${libsrc}make-docfile ${obj} ${shortlisp} ${SOME_MACHINE_LISP}

and map-ynp.elc is listed among the files in ${shortlisp}.

I've tried byte-compiling the files by hand with my older version of
Emacs ( of 2002-06-22, from CVS source)
but that doesn't work either, since it doesn't like the escape
character syntax in international/characters.el:

   ;; For indentation calculation.
   (define-category ?\s
     "This character counts as a space for indentation purposes.")

which gets the error:

  In toplevel form
   error: error (("Invalid escape character syntax"))

- --Steven Augart

Emacs-pretest-bug mailing list
------- End of forwarded message -------

reply via email to

[Prev in Thread] Current Thread [Next in Thread]