[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Anyone built Emacs with gcc-3.3?

From: Dhruva Krishnamurthy
Subject: Re: Anyone built Emacs with gcc-3.3?
Date: Wed, 09 Jul 2003 11:04:34 +0530

On Tue, 08 Jul 2003 15:39:47 +0100, "Jason Rumney" <address@hidden> said:
> Richard Stallman wrote:
> >     Yes, Emacs works with 3.2.3.  With 3.3 it dumps core on C-x C-c in
> >     __do_global_dtors_aux() after Fkill_emacs() calls exit().
> > 
> > I have a hunch that relates to unexec.  Perhaps unexec fails to
> > preserve some of the data that __do_global_dtors_aux uses.
> > 
> > Debugging the details is the only way to proceed.
> Someone else reported yesterday that a recent version of ld from 
> binutils has changed the position of some of the data segments in ELF 
> executables, causing problems with unexec. I think it is worth 
> investigating if this is really the cause of the gcc 3.3 problems, as it 
> could save a lot of debugging.

I had sent an email to the list:
I had tried building GNU Emacs with GCC 3.3 and had encountered a
problem which I have raised as a bug in GCC bugzilla(#9816).
I tried again using a newer port of GCC 3.3 and GCC 3.4 (not an official
port though) from:

I am unable to build or even progress to get an emacs.exe (executable).
With the earlier port of GCC 3.3, I could build a bare emacs executable
which failed in compiling elisp files.
If someone has a link to a GCC 3.3 port on W2K (Win32/MinGW), please let
me know. I will try to do some extensive testing. Unfortunately, I do not
have the older GCC 3.3 port with me now!
 As the problem is happening on Windows 2000 (W2K) platform, I feel it is
 not releted to 
unexec and specific to ELF. On W2K, I am not sure it uses 'ld' for
linking. So, modifications to 'ld' may not be the cause.

with regards,
Dhruva Krishnamurthy
Web: http://schemer.fateback.com/

reply via email to

[Prev in Thread] Current Thread [Next in Thread]