[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: make bootstrap fails.

From: Luc Teirlinck
Subject: Re: make bootstrap fails.
Date: Mon, 2 Feb 2004 08:28:30 -0600 (CST)

Kai Grossjohann wrote:

   Luc Teirlinck <address@hidden> writes:

   > Actuallly, what is strange in the case of the OP is that he got an
   > error message saying that src did not exist.  That is strange, because
   > at least the version of bash I am using (bash2.05b.0) always
   > _implicitly_ adds a colon at the _end_ of CDPATH by trying out the
   > current directory if nothing else worked.

   Does the OP use bash?


I should have checked better.  When bash is invoked as sh, it indeed
does not check ./ if nothing else worked.  With CDPATH=~/src, I get
the same errors as the OP when doing make bootstrap.  The Makefile
uses /bin/sh.  (Which shell the user uses is irrelevant, because bash
does not _really_ add a colon to the end of CDPATH.  It just gets the
same behavior by checking the current directory if nothing else worked.)



reply via email to

[Prev in Thread] Current Thread [Next in Thread]