[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: address@hidden: Detached minibuffer cropped text]

From: Marshall, Simon
Subject: RE: address@hidden: Detached minibuffer cropped text]
Date: Thu, 22 Jun 2006 12:19:17 +0100

Here's yet another quirk that may help track down the problem.  From the
original bug report, if I do:

xrdb -load
src/emacs -Q --font=9x15 --eval '(setq minibuffer-frame-alist (quote ((width
. 80) (height . 1))) initial-frame-alist (quote ((minibuffer))))'

Then the detached minibuffer has insufficient space for the trailing parts
of 9x15 characters such as "y".  Also, there are a few pixels to the right
of the right fringe.

If I put WM focus in the detached minibuffer and do:

M-x set-frame-font RET 9x15bold RET

Then Emacs resizes the minibuffer frame to have sufficient height for 9x15
characters and removes the extra pixels to the right of the right fringe.
The same thing happens if the default font is 9x15bold and then I change it
to 9x15.

This suggests to me that it is somehow a problem within Emacs - it does not
get it right on startup but it does get it right if the font is changed
while running.

How can I help you track the cause of this?  Simon.

> -----Original Message-----
> From: Marshall, Simon 
> Sent: 20 June 2006 09:51
> To: 'David Kastrup'; 'address@hidden'
> Cc: 'address@hidden'
> Subject: RE: address@hidden: Detached minibuffer 
> cropped text]
> > address@hidden (Kim F. Storm) writes:
> > 
> > > "Marshall, Simon" <address@hidden> writes:
> > >
> > >> Hi Kim, that does sound quite right either - the
> > minibuffer frame is
> > >> specified to have a height of 1, but you see 2 lines.  
> Or are you 
> > >> including the WM title bar?
> > >
> > > The display engine requires that window height is an whole
> > multiple of
> > > the default frame line height.  So if 1 line is not enough,
> > the next
> > > choice is 2 lines.
> > >
> > > I don't know why Emacs selects one line in your case, and 2
> > lines in
> > > my case.  It could be some property of the font -- I don't know.
> > 
> > Could be that the mode line font (or the minibuffer font after
> > font-lock) in one case is larger than one line of the default font, 
> > and in one case isn't.
> I don't think it can be the mode line font as the minibuffer 
> frame does not have one.  But I tried with different 
> minibuffer fonts, and it looks as though you both are on to 
> something.  I've attached a screenshot with:
> [1]  +  9267 Running  src/emacs -Q --font=5x8 --eval  ...
> [2]  -  9272 Running  src/emacs -Q --font=6x13 --eval  ...
> [3]     9275 Running  src/emacs -Q --font=9x15 --eval  ...
> [4]     9282 Running  src/emacs -Q --font=10x20 --eval  ...
> You can see that with the 10x20 font, the hanging parts of 
> the letters are displayed.  The other fonts are not displayed 
> with sufficient space for the letters.  I'm not sure it is 
> quite correct even with the 10x20 font though - there is 
> (exactly) enough space for the letters but not enough for the 
> bottom of the scrollbar nor cursor box.
> Note also that all fonts result in extra pixel space to the 
> right of the fringe.  Where does this come from???
> I began to wonder if this is due to my X server, if that is 
> the correct terminology, which is Hummingbird's Exceed (I 
> have the latest version).  I use Exceed on my PC to provide 
> the Solaris CDE environment on my PC.  Exceed is using the 
> Solaris' font server.  I am using a CVS Emacs built on 
> Solaris.  I tried displaying the same Emacs on a GNU/Linux 
> machine (some flavour of RedHat) which is presumably running 
> some Xfree86 server or something.  On that display, I do not 
> see a problem with either character space or fringe space.  
> So presumably it is related to the information that Emacs is 
> getting from the Solaris font server via Exceed?  I do not 
> know how to determine where the problem lies: it may be that 
> Emacs is not dealing with the information properly.  I do not 
> see any problems with any other applications I use.
> There is an additional problem that may help here.  If I 
> start Emacs with:
> src/emacs -Q --geometry=80x20 --font=9x15
> Then under Exceed I get an Emacs frame containing a *scratch* 
> buffer whose window is 78x17 in size as reported by 
> window-width and window-height.  On the GNU/Linux box, the 
> window is 80x19.
> How can I help find what the problem is?
> Simon.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]