[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: trunk not building on OSX

From: Jan Djärv
Subject: Re: trunk not building on OSX
Date: Thu, 17 May 2012 10:11:21 +0200


I had a similar experiece on GNU/Linux about a year ago.  Dumping Emacs would 
randomly crash with a segmentation violation.  Just running make again usually 

Turns out bad RAM was the cause.  Could this be similar?

        Jan D.

16 maj 2012 kl. 20:33 skrev Randal L. Schwartz:

>>>>>> "Jan" == Jan Djärv <address@hidden> writes:
> Jan> Hello.
> Jan> I do not have this problem. How do you configure Emacs?
> This was a weird problem, and I think there's still a problem somehow.
> I did a git bisect between the version the day before, and the broken
> version.  Each time, I did a "git clean -f -x" which wipes everything
> but the commit, and:
>  ./autogen.sh
>  ./configure --with-ns --without-x --without-dbus \
>  --with-jpeg=no --with-gif=no --with-tiff=no --prefix=/tmp/emacs
> to configure, followed by "make clean bootstrap install" to build.
> Now the weird part.  Every single one I did, worked just fine.
> So the bisect told me the "last good commit" was in fact the one before
> the origin/master.
> On a whim, I built origin/master again... and this time it worked.
> It should not have.  I was unable to get it to *fail* as it had earlier,
> even though I was building exactly the same way.
> Is there some part of the build running in parallel, and I was running
> into timing issues?  I've actually seen this error before, but only
> sporadically.
> -- 
> Randal L. Schwartz - Stonehenge Consulting Services, Inc. - +1 503 777 0095
> <address@hidden> <URL:http://www.stonehenge.com/merlyn/>
> Smalltalk/Perl/Unix consulting, Technical writing, Comedy, etc. etc.
> See http://methodsandmessages.posterous.com/ for Smalltalk discussion

reply via email to

[Prev in Thread] Current Thread [Next in Thread]