[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Difficulty applying multi-file patches from within emacs (Was: Propo

From: Tino Calancha
Subject: Re: Difficulty applying multi-file patches from within emacs (Was: Proposal: new mode-line `%'-construct %o ..)
Date: Tue, 23 May 2017 20:21:11 +0900 (JST)
User-agent: Alpine 2.20 (DEB 67 2015-01-07)

On Sun, 21 May 2017, Kaushal Modi wrote:

I attempted M-x ediff-patch-file.

But then I ended with with an issue which is well-described by Michael (copied 
on this email) in a thread on help-gnu-emacs back
in Feb this year: 

It's the same issue that when I specify the root dir for all the patches to be 
applied, ediff-patch-file in my case (epatch in
the case in that Feb 2017 thread) does not parse the subdirs for the unified 
diff format headers.

In that thread, Eli suggests using patch utility directly from the 
command-line. But I really wished ediff-patch-file/epatch
worked correctly when applying multi-file patches.

So the reason for this thread is:

- Has anyone been able to apply multi-file patches from within emacs? If so, 
- If someone has worked out the issues with ediff-patch-file/epatch for this 
issue and the solution is lying around in their
workarea, it would be awesome if they provided a patch to fix it upstream :)
- I followed that Feb 2017 help thread, and it wasn't clear if a solution was 
reached.. was it?
Well, i am not really using `ediff-patch-file' (a.k.a. `epatch') but i have an old patch for this issue. That said, i don't think this patch is the ultimate solution, but at least improves the current situation a bit.
I am going to post it in Bug#26028.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]