[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: emacs vs emacs -nw

From: Tim Cross
Subject: Re: emacs vs emacs -nw
Date: Wed, 31 May 2017 08:34:55 +1000

While a long shot, also check that the GUI and terminal emacs are the same version. I have seen a situation where emacs was installed from brew using the cask (i.e. emacsforosx binary), which creates Emacs.app but does not create a link for 'emacs'. As a result, when you run GUI via dock you get latest Emacs.app version, but when you run from terminal, you get /usr/bin/emacs (very old emacs 21 or 22, cna't remember). Unlikely, but worth checking.

On 31 May 2017 at 04:33, Alan Third <address@hidden> wrote:
On Tue, May 30, 2017 at 08:09:58AM +0900, Jean-Christophe Helary wrote:
> > On May 30, 2017, at 2:47, Eli Zaretskii <address@hidden> wrote:
> >
> >> emacs and emacs -nw seem to have different initialisation
> >> parameters that I can't seem to disable even when I run emacs -Q.
> >> I'd like to have hints for further investigation...
> >>
> >> Practically speaking, emacs in a graphical frame seems to re-bind
> >> a number of org-mode keys while emacs -nw gets the expected
> >> bindings.
> >>
> >> This happens *even* when I run emacs -Q vs emacs -Q -nw
> >
> > On what OS?
> macOS. I also get this behavior in Aquamacs.

Check list/term/ns-win.el. It claims it’s loaded when Emacs detects
that NS windows are going to be used, in which case it might be the
source of your mystery rebindings.
Alan Third



Tim Cross

reply via email to

[Prev in Thread] Current Thread [Next in Thread]