[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problems building master on macOS

From: Ken Raeburn
Subject: Re: Problems building master on macOS
Date: Mon, 19 Jun 2017 22:47:15 -0400

On Jun 19, 2017, at 22:27, Chad Brown <address@hidden> wrote:

HEAD has been broken for me for a few days, failing to configure with:

config.status: error: cannot find input file: `src/emacs-module.h.in’

I’m not sure when this started; I noticed recently that the configure machinery had changed, had some free time, and decided to do a distclean and bootstrap. ./autogen.sh asked me to rerun ./autogen.sh git, which was fine, but configure failed near the end, unable to find the above file. I then tried again with —without-modules, to no avail.

A little digging suggests that this commit is related:

commit c66a7cce17ac4b9cde6bf49232aaa59c1c73404e
Author: Philipp Stephani <address@hidden>
Date:   Sat Jun 17 19:12:45 2017 +0200

That’s the commit that added emacs-module.h.in, in place of emacs-module.h.

I just tried building from a clean tree on macOS and it seems okay. It sounds like there’s something amiss in your checked-out tree.  Try “git clean -fdx” and “git reset --hard” (or a fresh checkout in a new tree) and see if that fixes it…


reply via email to

[Prev in Thread] Current Thread [Next in Thread]