[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[SOLVED] (was: very different start up for emacs master compared with 3

From: Uwe Brauer
Subject: [SOLVED] (was: very different start up for emacs master compared with 3 month ago)
Date: Tue, 13 Aug 2019 12:51:33 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

>>> "EZ" == Eli Zaretskii <address@hidden> writes:

   >> From: Uwe Brauer <address@hidden>
   >> Date: Fri, 09 Aug 2019 17:47:03 +0200
   >> | Version                                  | init file | without init |
   >> |------------------------------------------+-----------+--------------|
   >> | b06917a4912a60402025286d07d4a195749245c4 | 50 sec    | 1-2 sec      |
   >> | 1d75604eaded6a8482d28d57bc8e6a4d99d5caee | 15 sec    | 1-2 sec      |
   >> #+end_src
   >> Any idea whats up?
   >> How can I debug this?

   > Bisect your customizations to see which part takes the lion's share of
   > the time, I'd say.

It was my fault. I bisected different commits (using mercurial)

My configuration script was

./configure CFLAGS='-O0 -g3' --enable-checking='yes,glyphs' 
--enable-check-lisp-object-type --prefix=/opt/emacs27 --with-x-toolkit=athena 

Which slowed down loading considerably (must have needed that some time

I switched back to
 ./configure --prefix=/opt/emacs27 --with-x-toolkit=athena --with-mailutils

And everything was back to normal. Sorry.

At least now I know how to modify emacs-repository-version, in order to
include mercurial, but as it seems there is anyhow no mercurial hacker
around needing this.

Attachment: smime.p7s
Description: S/MIME cryptographic signature

reply via email to

[Prev in Thread] Current Thread [Next in Thread]