[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: The netsec thread

From: Paul Eggert
Subject: Re: The netsec thread
Date: Fri, 23 Aug 2019 01:19:19 -0700
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:60.0) Gecko/20100101 Thunderbird/60.8.0

Lars Ingebrigtsen wrote:
I've tried the resulting code, and everything seems to work OK to me,
but please let me know whether you see any new TLS-related problems
while browsing or something.

I had a problem building it on Fedora 30 which uses GnuTLS 3.6.8, because starting in GnuTLS 3.6 the functions gnutls_compression_get and gnutls_compression_get_name are deprecated and cause compile-time errors when one builds with --enable-gcc-warnings. If you override the compile-time errors the compatibility stubs in libgnutls return null values, and some network-stream-tests fail.

I temporarily worked around the build problem by installing the attached patch which omits calls to these functions in GnuTLS 3.6 and later, but this doesn't fix the runtime issues. Is that something you could take a look at?

Attachment: 0001-Get-the-Gnutls-code-compiling-on-Fedora-30.patch
Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]