[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: If undo-only why not a redo-only?

From: Drew Adams
Subject: RE: If undo-only why not a redo-only?
Date: Tue, 9 Jun 2020 08:19:25 -0700 (PDT)

>> Ohh, now I got it. 
>> Sorry, but the name `undo-redo` was not clear for me at all 
> Can't resist pointing out that that is quite  understandable.
> The "prefix-with-library" name convention is fraught with
> these little misunderstandings. It's arguably the last bad
> option we have now, but we would need a proper namespace
> system to fix them: renaming can only do so much.

I was thinking the same thing.

Using hyphen to separate both pkg prefix and other parts of
a name is confusing.  Better, perhaps, to use something like
`/' or `:' as pkg separator, while waiting for a real,
namespace solution.

But didn't you mean "least bad", not "last bad".  Surely it's
not the last one that can be found. ;-)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]