emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [elpa] externals/brief 362d629671: Brief mode v5.88.22 release for v


From: Stefan Monnier
Subject: Re: [elpa] externals/brief 362d629671: Brief mode v5.88.22 release for various enhancements and bug fixes
Date: Sun, 29 Jan 2023 21:50:17 -0500
User-agent: Gnus/5.13 (Gnus v5.13)

>  (eval-when-compile
> -  (require 'cl-lib)
> +  (if (version< emacs-version "27.0")
> +      (progn
> +        (require 'cl) ;; Package cl is deprecated for Emacs27+
> +        (require 'cl-macs))
> +    (require 'cl-lib))

This looks like a regression resulting from a misunderstanding.
What are you trying to do here?

The rest of the code only uses `cl-lib` functionality, so (require 'cl)
will only be useful because if it internally does (require 'cl-lib).
In Emacs<24.3, this will fail because (require 'cl) will not define the
macros that the rest of the code needs (e.g. `cl-eval-when`, `cl-loop`, ...).


        Stefan




reply via email to

[Prev in Thread] Current Thread [Next in Thread]