emacs-devel
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Emacs Lisp Linter fail to identify function defined in a "use-packag


From: Emanuel Berg
Subject: Re: Emacs Lisp Linter fail to identify function defined in a "use-package" block
Date: Fri, 13 Oct 2023 05:33:19 +0200
User-agent: Gnus/5.13 (Gnus v5.13)

I have now used elint on all my Elisp, totalling
196 files and 10 907 sloc.

The problems with elint, using `elint-current-buffer', are:

  - &rest arguments
  - `pcase'
  - `pcase-let'
  - lexical `let'-closures

The problems with vanilla Emacs source files, that are brought
to our attention thanks to elint, are:

  - they do not `provide' (e.g. startup.el)
  - they provide incorrectly (float-sup.el)
  - they don't use provide good enough (dired.el)

Of these problems, the byte-compiler, which is also a de facto
Elisp linter, only has the problem with lexical let-closures.
That particular problem can be remedied with
`declare-function' - but shouldn't have to be, and that method
doesn't work for elint.

The problem with vanilla Emacs sources files are not reported
by the byte-compiler.

-- 
underground experts united
https://dataswamp.org/~incal




reply via email to

[Prev in Thread] Current Thread [Next in Thread]