[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Orgmode] Re: Compilation errors with 4.73 (undefined functions, wrong n

From: Holger Arnold
Subject: [Orgmode] Re: Compilation errors with 4.73 (undefined functions, wrong number of parameters)
Date: Sat, 12 May 2007 17:31:03 +0200
User-agent: KMail/1.9.5

> On 5/11/07, Holger Arnold <address@hidden> wrote:
> > Hello,
> >
> > when I try to byte-compile org-mode (e.g. by doing make), I get a number
> > of error messages about undefined functions and wrong number of
> > parameters (I have attached the output of a make).  When I then do M-x
> > org-mode, I get "Symbol's function definition is void: find-if".
> >
> > Without byte-compiling, org-mode seems to work at first sight, but I
> > don't know if some functions are deactivated or not broken.
> >
> > I'm using org-mode 4.73 on GNU Emacs 21.3.1 on openSUSE 10.2.  I didn't
> > have these problems with version 4.69 of org-mode.
> >
> > Does anyone know what's wrong here?
> >
> >
> > Holger
>     It's been a while since I've compiled org.  I run uncompiled to
> get more useful stacks and have easier debug.  It's slower but
> educational.  I know when I did compile I always got a mess of errors.
>  I just ignored them and everything worked.  For me I think it was
> attempts to use packages I didn't have installed.  The ones about the
> number of args would worry me.  After you compile it, does it work?
> Edd

The compiled version does not work, as I cannot activate org-mode.

When I use the uncompiled version, at least the functions I am using *seem* to 
work.  I would expect a problem when one of the undefined functions (as 
find-if) gets called or one of the function calls with the wrong number of 
parameters is reached.  But I don't know in which part of org-mode these 
functions are being used.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]