[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [O] [solved] target file of capture template does not save

From: tom
Subject: Re: [O] [solved] target file of capture template does not save
Date: Thu, 2 Aug 2018 08:19:38 -0500

On Thu, Aug 2, 2018 at 8:13 AM tom <address@hidden> wrote:
You guys are so skillful and awesome you helped me without saying a word!

After looking around at 

I just added a third hook,
(add-hook 'org-capture-mode-hook 'org-save-all-org-buffers)

I'll mark this solved. Org rocks, I don't rock.

On Wed, Aug 1, 2018 at 8:41 AM tom <address@hidden> wrote:
Me again. Let me try to provide a bit more info. I'm using xdotool to call "emacsclient -c -e '(org-capture)'". In my init.el, I have both

(add-hook 'org-capture-mode-hook 'make-frame)
(add-hook 'org-capture-mode-hook 'delete-frame)

my capture template writes to, say, "beans.org."  

I swoop in with the mouse, choose the template, finish, and the capture frame goes away. perfect. I don't open or ever see beans.org. But when I do visit the file, it is sitting there unsaved. How can I have it automatically save for me? Modify the org-capture-mode hook? If that's the case, may I have some help with the modification? Or am I missing something else?


On Fri, Jul 27, 2018 at 7:42 PM tom <address@hidden> wrote:
Hey guys, I have a capture template set up pretty much the way I want it,  but the file it writes to does not save afterwards. It's a table line template with some prompts, :prepend, :table-line-position, and :kill-buffer.

Why doesn't the file save? Is it supposed to?

reply via email to

[Prev in Thread] Current Thread [Next in Thread]