[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[FR-users] Re: [Foxgui-users]FreeRIDE and fxscintilla, continued

From: Daniel Berger
Subject: [FR-users] Re: [Foxgui-users]FreeRIDE and fxscintilla, continued
Date: Mon, 05 May 2003 14:52:58 -0600

"address@hidden" wrote:
> On Mon, 05 May 2003 13:34:04 -0600, Daniel Berger <address@hidden> wrote :
> > I managed to narrow down the culprit when it came to building FOX using
> > Sun's ld - libtiff.
> >
> > For some reason the libtiff library still manages to build successfully,
> > despite a truckload of ld errors (whether built with Sun's ld or GNU
> > ld).  Unfortunately, these errors are not printed to the terminal during
> > the build phase, nor are they fatal.  They are, however, logged in the
> > config.log file, and that's why I didn't notice them at first.
> >
> > Once I discovered this, I completely removed the libtiff libraries from
> > my system and rebuilt FOX from scratch, this time using Sun's ld.  For
> > the first time, it worked!  Then I rebuilt fxscintilla and fxruby (yes,
> > I built with fxscintilla support).  They also built successfully using
> > Sun's ld.
> Slightly off-topic, but do you even need libtiff support for FreeRIDE? I
> figured they were only using PNG icons. But I digress.
> > However, when I startup FreeRIDE now, I get this:
> >
> > >/opt/bin/ruby freeride.rb
> > Failing to load: rubyide_tools_source_parser
> > Failing to load: rubyide_tools_fox_source_browser
> > Failing to start: rubyide_tools_source_parser
> > Failing to start: rubyide_tools_fox_source_browser
> >
> > Any ideas?
> You didn't specifically say if the FXRuby example programs worked. Did they?
> In particular, does the scintilla-test.rb example program run? If these
> don't work, then FreeRIDE definitely isn't going to work.

Believe it or not, the scintilla-test.rb example core dumps (actually
most do, now that I try them), yet FreeRIDE *does* work.  Well, until I
try to use the debugger anyway, at which point it dies with an
"incompatible marshal file format" error:

redist/drb/drb.rb:124:in `load': incompatible marshal file format (can't
be read) (TypeError)
        format version 4.6 required; 4.8 given
        from (druby://sp5wd-b1:33059) redist/drb/drb.rb:124:in `load'
        from (druby://sp5wd-b1:33059) redist/drb/drb.rb:143:in
        from (druby://sp5wd-b1:33059) redist/drb/drb.rb:458:in `proc'
        from (druby://sp5wd-b1:33059) redist/drb/drb.rb:499:in `loop'
        from (druby://sp5wd-b1:33059) redist/drb/drb.rb:499:in `proc'
        from (druby://sp5wd-b1:33059) redist/drb/drb.rb:450:in `start'
        from (druby://sp5wd-b1:33059) redist/drb/drb.rb:450:in `proc'
        from (druby://sp5wd-b1:33059)
./plugins/rubyide_tools_debugger/debuggee.rb:61:in `run'
         ... 31 levels...
        from freebase/lib/freebase/core.rb:35:in `new'
        from freebase/lib/freebase/core.rb:35:in `startup'
        from freeride.rb:55:in `startup'
        from freeride.rb:68
> Lyle
> P.S. I couldn't tell if you cross-posted this to both the foxgui-users and
> freeride-users mailing lists, but it is probably a little off-topic for the
> foxgui-users list. If we do narrow it down to a FOX-specific problem, of
> course, this is a good place to hash it out.

I only posted to the foxgui-users list, though I probably should have
posted to both, but since I'm not actually on the FreeRIDE mailing list
In any case, I felt the ld/fox issue and the ELF warning warranted
posting to foxgui-users.  Of course, I'm guessing that the ELF warning
is a FOX/gcc/ld issue and not FXRuby or FXScintilla, but that's just a
gut feeling at the moment.



PS - I cross posted this time.  Hope that's ok - I'm not up on
cross-posting etiquette (because I almost never do it).

reply via email to

[Prev in Thread] Current Thread [Next in Thread]