[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Mon, 19 May 2003 22:23:32 +0200 (CEST)
I changed the name of a structure in the current CVS:
struct_mime_to_skip is now mime_to_skip_t.
I would like that some standards be respected. I do not force you to use them
code in gtktalog (I did not respect them myself in the past), but I follow them
projets now: they are good.
- Structures should be named with a suffix _t
- Variables should have either explicit names, or really short names with 1 or
For exemple: I noticed a variable called "glist". This is a bad idea for some
what if the type of that variable changes ? And it is rather long for a
- code should be indented with GNU indent with no option. This is just for the
homogeneity of the code, and to have shorter diffs in the CVS.
Only the new code is concerned. We will do some code cleanup only when
- Homepage - http://ymettier.free.fr - http://www.logicacmg.com -
- GPG key - http://ymettier.free.fr/gpg.txt -
- Maitretarot - http://www.nongnu.org/maitretarot/ -
- GTKtalog - http://www.nongnu.org/gtktalog/ -
|[Prev in Thread]
||[Next in Thread]|
- [Gtktalog-devel]coding standards,
Yves Mettier <=